Current Status: Resolved - Our engineers have isolated and resolved the issue impacting NBN services. If customers are still offline they should reboot their router and contact our support team if they are still offline.
Next Update/ETR: MyOwnTel will monitor the situation for another half hour before declaring the issue resolved.
Posted Nov 20, 2025 - 16:36 AEST
Identified
Current Status: Our engineers have isolated the issue to NBN network based customers only and identified the issue to be related to NNI failover handoff upstream. We are working with upstream engineers to rectify the issue.
Start Date and Time: 04:00
Next Update/ETR: MyOwnTel will continue to provide timely updates until this outage is resolved.
Posted Nov 20, 2025 - 09:36 AEST
Investigating
Current Status: Customers on NBN or Opticomm networks are reporting their services are offline. Investigation has indicated that this issue is only affecting some customers in VIC, SA and TAS. The majority of customers in these states are online.
Posted Nov 20, 2025 - 09:13 AEST
This incident affected: VIC - Internet Services (VIC - ACG Broadband, VIC - NBN, VIC - Opticomm), TAS - Internet Services (TAS - ACG Broadband, TAS - NBN, TAS - Opticomm), and SA - Internet Services (SA - ACG Broadband, SA - NBN, SA - Opticomm).